WHITE PAPERS
from the files of
Networking Unlimited, Inc.

WebQuery@NetworkingUnlimited.com
14 Dogwood Lane, Tenafly, NJ 07670
Phone: +1 201 568-7810

Using the AUX Port on Cisco Routers for IP/IPX Router Communications

Copyright © 1999, Networking Unlimited, Inc. All Rights Reserved.

The need to support IPX routing as well as TCP/IP creates additional challenges when designing dial backup solutions. This paper shows how to support both IP and IPX routing between Cisco routers using PPP between the AUX ports connected to analog modems. While the example uses EIGRP for IP routing and RIP for IPX routing, the actual choice of routing protocols should be arbitrary as the routing protocol is used only to control the activation of floating static routes.

Background

While the Cisco documentation and configuration examples discuss using the auxiliary port on routers for PPP router to router links, there seems to be a lack of concrete examples of how to actually do it, particularly in a mixed protocol environment. The following configuration example shows how one client has been able to support both IP and IPX in a communications emergency using a normal POTS line, standard asynchronous modems, and no additional router hardware. This particular configuration is excerpted from a production network using Cisco proprietary EIGRP for IP routing and standard Novell 3.11 RIP for IPX routing. The remote 2503 router is configured to call the data center 4700 router and the expectation is that the link will remain up continuously for as long as needed by the remote. There is no provision for the 4700 to call the 2503, but it could be easily implemented by adding appropriate phone numbers, login scripts, and "interesting traffic" filters to the 4700 configuration.

In this sanitized version, the Ethernet on the 4700 is IP 192.168.1.0/24, IPX A00001; the Ethernet at the remote 2503 is 192.168.2.0/24, IPX A00002, and the Asynchronous link is IP 192.168.31.0/24, IPX B00002; and no other communications links or router features such as security are included.

Other remotes sharing the auxiliary port on the same 4700 would use their own unique IP address on the same asynchronous link subnet and define their own Ethernet IP and IPX networks. The 4700 configuration includes an example of a second caller named CALLER3. Although not required, the configuration starts PPP "manually" in order to continue to allow the auxiliary port to be used for maintenance access.

Calling Router


version 11.2
!
hostname CALLER
!
username CALLED password mumble
ip host TestAsync 192.168.31.1
ipx internal-network 123456
chat-script courier ABORT ERROR ABORT "NO " ABORT BUSY "" "at" "" "at&f" OK "atl1m1&b1&h1&r2&c1&d3&m4&k1s0=2" OK "at dt \T" TIMEOUT 90 CONNECT \c
chat-script async-login TIMEOUT 10 Username-\r-Username CALLER "Password:"mumbojumbo CALLED "ppp 192.168.31.2"
!
interface Ethernet0
 ip address 192.168.2.1 255.255.255.0
 ipx network A00002 encapsulation SAP
!
interface Async1
 ip address 192.168.31.2 255.255.255.0
 encapsulation ppp
 bandwidth 10
 async default routing
 async mode interactive
 ipx ipxwan 0 unnumbered CALLER
 ipx delay 30
 ipx output-rip-delay 200
ipx output-sap-delay 200
 ipx sap-interval 5
 dialer in-band
dialer idle-timeout 300
 dialer map ipx 0.0098.7654.0000 name CALLED broadcast 18005551212
 dialer map ip 192.168.31.1 name CALLED modem-script courier system-script async-login broadcast 18005551212
 dialer hold-queue 10 timeout 60
 dialer-group 1
ppp authentication chap
!
router eigrp 1
 network 192.168.2.0
 network 192.168.31.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1 150
ip route 0.0.0.0 0.0.0.0 192.168.31.1 160
ip route 192.168.31.0 255.255.255.0 Async1
access-list 102 deny eigrp any any
access-list 102 permit ip any any
access-list 902 deny rip
access-list 902 deny sap
access-list 902 permit any
!
dialer-list 1 protocol ip list 102
dialer-list 1 protocol ipx list 902
!
line aux 0
 password mumblemumble
script dialer courier
 login
 modem InOut
 transport input all
 rxspeed 38400
 txspeed 38400
 flowcontrol hardware
!
end

Unlike IP, IPX use of the user name is case sensitive. Make certain that there is an exact match between the hostname statement on the remote system and the local username and dialer map statement. Also make sure that the IPXWAN statement is an exact match of the local username. Otherwise IPX routing may fail.

The bandwidth and ipx delay statements are optional. They serve to allow the routing protocol to make useful routing decisions if the link is to be used to back up another link. Similarly, the IPX RIP and SAP tuning statements reduce the overhead of carrying Novell service advertisements over the slow asynchronous link. If the SAP interval is adjusted, both ends of the link must use the same value or else Novell advertised services may appear to disappear at random.

The IPX address in the dialer map statements is derived from the remote's internal network number and must also be correct for IPX routing to function. The six hex digits (left filled with leading zeroes, if required) of the internal network number become the third through eighth digits of the host ID portion in the dialer map with all other digits set to zero, including the network number.

Be careful with the dialer map and chat script lines. They can be very long and may wrap when displayed or edited, but they must be entered as a single line when configuring the router.

Called Router (Cisco 4700)

version 11.2
!
hostname CALLED
!
username CALLER password mumble

! Other callers get defined here. For example:
username CALLER3 password mumble3

ipx internal-network 987654
chat-script hayes ABORT "NO " ABORT ERROR "" "at" "" "at&f" OK "AT&C1&D2S0=1" OK
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0 secondary
 ipx network A00001 encapsulation SAP
!
interface Async1
 ip address 192.168.31.1 255.255.255.0
 encapsulation ppp
 bandwidth 10
 async default routing
 async mode interactive
 ipx ipxwan 0 unnumbered CALLED
 ipx delay 30
 ipx output-rip-delay 200
ipx output-sap-delay 200
 ipx sap-interval 5
 peer default ip address 192.168.31.254
 dialer in-band
 dialer idle-timeout 300
 dialer map ip 192.168.31.2 name CALLER broadcast
 dialer map ipx 0.0012.3456.0000 name CALLER broadcast

! Define other potential callers here. For example:
dialer map ip 192.168.31.3 name CALLER3 broadcast
 dialer map ipx 0.00ab.c123.0000 name CALLER3 broadcast
 dialer-group 1
 ppp authentication chap
 pulse-time 3
!
router eigrp 1
network 192.168.1.0

network 192.168.31.0
 no auto-summary
!
ip classless
dialer-list 1 protocol ipx permit
dialer-list 1 protocol ip permit
!
line aux 0
 password 7 mumbojumbo
script startup hayes
 script reset hayes
 login
 modem InOut
 transport input all
 stopbits 1
 rxspeed 38400
txspeed 38400
 flowcontrol hardware
!

end

Other remotes sharing the same auxiliary port on the 4700 would use their own unique IP address on the same asynchronous link subnet and define their own Ethernet IP and IPX networks. The 4700 configuration above includes an example of a second caller named CALLER3 with Ethernet IP 192.168.3.0/24 and IPX A00003; IPX internal network number of abc123; and asynchronous port address IP 192.168.31.3.

As a closing note, be aware that all packets in and out the auxiliary port are process switched. However the added CPU load is usually not an issue since the auxiliary port has a maximum data rate of only 38,400 bps.



Home Page | Company Profile | Capabilities | Coming Events | Case Studies | White Papers | Book

Copyright 1999-2000 © Networking Unlimited Inc. All rights reserved.